$re = '/^[A-Za-z0-9]*?([0-9]+)$/m';
$str = 'a123
a2a123
123
abc
123abc
()123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);