package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^%]|^)(?:%%)*(%)(?:[^%]|$)`)
var str = `%скидка 10%% цена в акции = пусто цена в 10%%% магазине %d %скидка % на %, това р в магазине 25%%%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}