$re = '/(?:[^%]|^)(?:%%)*(%)(?:[^%]|$)/';
$str = '%скидка 10%% цена в акции = пусто цена в 10%%% магазине %d %скидка % на %, товар в магазине 25%%%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);