#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(?:\s*[A-Za-z_][A-Za-z0-9]*\s*(?:=\s*(?:[A-Za-z0-9]+(?:[+\/*-][A-Za-z0-9]+)?|[0-9]+(?:\.[0-9]+)?(?:[+\/*-][0-9]+(?:\.[0-9]+)?)?|"[^"]*"|'[^']*'))?\s*,)*\s*[A-Za-z_][A-Za-z0-9]*\s*(?:=\s*(?:[A-Za-z0-9]+(?:[+\/*-][A-Za-z0-9]+)?|[0-9]+(?:\.[0-9]+)?(?:[+\/*-][0-9]+(?:\.[0-9]+)?)?|"[^"]*"|'[^']*'))?\s*;"
Local $sString = "a;" & @CRLF & _
"a, _b2;" & @CRLF & _
"a, _b2=0;" & @CRLF & _
"a=1, _b2=0;" & @CRLF & _
"a=1+1, _b2=a+1, c, d=555, e;" & @CRLF & _
"a=2.33;" & @CRLF & _
"b=3;s;" & @CRLF & _
"a12 = ,b2, c3 , d4;" & @CRLF & _
"a= , b2 = 1;" & @CRLF & _
"a = ;" & @CRLF & _
"a = '23;" & @CRLF & _
"a = 50, b = a+1" & @CRLF & _
"a = a.23;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")