$re = '/^\s+|\s+$|\s+(?=\s)/m';
$str = ' ahbfjda kadsj cccadkjnskvnskv ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;