import re
regex = re.compile(r"^\s+|\s+$|\s+(?=\s)", flags=re.MULTILINE)
test_str = " ahbfjda kadsj cccadkjnskvnskv "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)