import Foundation
let pattern = #"(?<=\d)(?=(\d\d\d)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"298444215"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)