package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-HJ-NP-RT-Y]{3}-[^3]{4}$`)
var str = `ABC-1245
ABS-6789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}