$re = '/^[A-HJ-NP-RT-Y]{3}-[^3]{4}$/m';
$str = 'ABC-1245
ABS-6789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);