#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*[a-z]+:"
Local $sString = "link: https://example.com text: foo" & @CRLF & _
"link: #" & @CRLF & _
"link:" & @CRLF & _
"site.find('notes').foo(':')" & @CRLF & _
"site.link" & @CRLF & _
"link"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")