re = /^\s*[a-z]+:/m
str = 'link: https://example.com text: foo
link: #
link:
site.find(\'notes\').foo(\':\')
site.link
link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end