#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*?((S\d+-S\d+)?(Season(.?\s?)\d+)-\d+)"
Local $sString = "Wilfred.US.S01-S04.Season.1-4.Complete.720p.HDTV.X264-MRSK" & @CRLF & _
"Wilfred.US.S01.Season.1.Complete.720p.HDTV.X264-MRSK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")