$re = '/.*?((S\d+-S\d+)?(Season(.?\s?)\d+)-\d+)/m';
$str = 'Wilfred.US.S01-S04.Season.1-4.Complete.720p.HDTV.X264-MRSK
Wilfred.US.S01.Season.1.Complete.720p.HDTV.X264-MRSK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);