package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`wget\s*(?:-\w+)?\s*(.*)`)
var str = `wget -qO http://www.google.com
wget http://www.google.com
wget `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}