$re = '/wget\s*(?:-\w+)?\s*(.*)/';
$str = 'wget -qO http://www.google.com
wget http://www.google.com
wget ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);