import re
regex = re.compile(r"([^/])/$", flags=re.MULTILINE)
test_str = ("/\n"
"beta/alpha/")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)