#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xsm) # free-spacing mode, DOTALL, multi-line" & @CRLF & _
"(?=.*?blue) # if blue isn't there, fail without delay" & @CRLF & _
"" & @CRLF & _
"###### Recursive Section ######" & @CRLF & _
"# This section aims to balance empty lines with digits, i.e." & @CRLF & _
"# emptyLine,emptyLine,emptyLine ... ~1~2~3" & @CRLF & _
"# The last digit block is captured to Group 2, e.g. ~3" & @CRLF & _
"(?= # lookahead" & @CRLF & _
"( # Group 1" & @CRLF & _
" (?: # skip one line that doesn't contain blue" & @CRLF & _
" ^ # start of line" & @CRLF & _
" (?:(?!blue)[^\r\n])* # zero or more chars not followed by blue" & @CRLF & _
" (?:\r?\n) # newline" & @CRLF & _
" ) " & @CRLF & _
" (?:(?1)|[^~]+) # recurse Group 1 OR match all non-tilde chars" & @CRLF & _
" (~\d+) # match a sequence of digits" & @CRLF & _
")? # End Group 1" & @CRLF & _
") # End lookahead. " & @CRLF & _
"" & @CRLF & _
"# Group 2, if set, now contains the number of lines skipped" & @CRLF & _
".*? # lazily match chars up to... " & @CRLF & _
"blue # match blue" & @CRLF & _
".*? # lazily match chars up to... " & @CRLF & _
"(?(2)\2) # if Group 2 is set, match Group 2" & @CRLF & _
"~ # Match the next tilde" & @CRLF & _
"\K # drop what was matched so far" & @CRLF & _
"\d+ # match the next digits: this is the match " & @CRLF & _
""
Local $sString = "Paint it white" & @CRLF & _
"Paint it black" & @CRLF & _
"Why not blue?" & @CRLF & _
"Or red or brown?" & @CRLF & _
"" & @CRLF & _
"~1~2~3~4~5~6~7~8~9~10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")