const regex = /,(?!\s+and\b)(?=[^,]+$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',(?!\\s+and\\b)(?=[^,]+$)', 'gmi')
const str = `1, 2, 3, 4
1, 2, 3, and 4
1,2
1234`;
const subst = `, and `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);