$re = '/,(?!\s+and\b)(?=[^,]+$)/mi';
$str = '1, 2, 3, 4
1, 2, 3, and 4
1,2
1234';
$subst = ", and ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;