using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)(['""])(?:\\\1|(?!\1).)*\1";
string input = @"
\""Hello, is it 'me youre looking for'
""Hello"", is it 'me you\'re looking for'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}