re = /(?<!\\)(['"])(?:\\\1|(?!\1).)*\1/
str = '
\\"Hello, is it \'me youre looking for\'
"Hello", is it \'me you\\\'re looking for\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end