#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{(?!token[12]\}).*?\}"
Local $sString = "qwert yuiop" & @CRLF & _
"qwert{token1}yuiop" & @CRLF & _
"qwert{token1}{token2}yuiop" & @CRLF & _
"qwert {token1} {token2} yuiop" & @CRLF & _
"" & @CRLF & _
"qwert {badtoken} yuiop" & @CRLF & _
"qwert { badtoken} yuiop" & @CRLF & _
"qwert {badtoken } yuiop" & @CRLF & _
"qwert { token1} yuiop" & @CRLF & _
"qwert {token1 } yuiop" & @CRLF & _
"qwert { token1 } yuiop" & @CRLF & _
"qwert {badtoken} {token1} yuiop" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")