import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?!token[12]\\}).*?\\}";
final String string = "qwert yuiop\n"
+ "qwert{token1}yuiop\n"
+ "qwert{token1}{token2}yuiop\n"
+ "qwert {token1} {token2} yuiop\n\n"
+ "qwert {badtoken} yuiop\n"
+ "qwert { badtoken} yuiop\n"
+ "qwert {badtoken } yuiop\n"
+ "qwert { token1} yuiop\n"
+ "qwert {token1 } yuiop\n"
+ "qwert { token1 } yuiop\n"
+ "qwert {badtoken} {token1} yuiop\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}