package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div\ class="myclass">
[\s\S]*?
</div>
(*SKIP)(*FAIL)
|
<a[^>]*>.*?</a>`)
var str = `<p>Hi Hello <a href="#">World</a></p>.
This is <div class="myclass">testing <a href="#">content</a>.
some more content</div>. One more <a href="#"> Link </a>.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}