re = /<div\ class="myclass">
[\s\S]*?
<\/div>
(*SKIP)(*FAIL)
|
<a[^>]*>.*?<\/a>/x
str = '<p>Hi Hello <a href="#">World</a></p>.
This is <div class="myclass">testing <a href="#">content</a>.
some more content</div>. One more <a href="#"> Link </a>.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result