using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<protokoll>[a-z]*):\/\/?(?<domain>[a-z.-]*)?(?<file>[^?#]*)?[?](?<parameter>[^#]*)?[#](?<anker>.*)?";
string input = @"http://www.baumarkt.de/sub/kataloge.php?projekt=bm#start";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}