re = /(?<protokoll>[a-z]*):\/\/?(?<domain>[a-z.-]*)?(?<file>[^?#]*)?[?](?<parameter>[^#]*)?[#](?<anker>.*)?/
str = 'http://www.baumarkt.de/sub/kataloge.php?projekt=bm#start'
# Print the match result
str.match(re) do |match|
puts match.to_s
end