import re
regex = re.compile(r"^https?://www\.imdb\.com/[Tt]itle[?/]([a-zA-Z0-9]+)", flags=re.MULTILINE)
test_str = ("http://www.imdb.com/Title/tt2618986\n"
"http://www.google.com/tt2618986\n"
"https://www.imdb.com/Title/tt2618986\n"
"http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")