re = /^https?:\/\/www\.imdb\.com\/[Tt]itle[?\/]([a-zA-Z0-9]+)/m
str = 'http://www.imdb.com/Title/tt2618986
http://www.google.com/tt2618986
https://www.imdb.com/Title/tt2618986
http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end