package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?://www\.imdb\.com/[Tt]itle[?/][a-zA-Z]+([0-9]+)`)
var str = `http://www.imdb.com/Title/tt2618986
http://www.google.com/tt2618986
https://www.imdb.com/Title/tt2618986
http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}