import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?://www\\.imdb\\.com/[Tt]itle[?/][a-zA-Z]+([0-9]+)";
final String string = "http://www.imdb.com/Title/tt2618986\n"
+ "http://www.google.com/tt2618986\n"
+ "https://www.imdb.com/Title/tt2618986\n"
+ "http://www.imdb.com/title/tt1979376/?ref_=nv_sr_1?ref_=nv_sr_1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}