# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h6 class=\"panel-title\"><i class=\"icon-file-music2\"><\/i>(.*?)<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"(.*)\" data-placement=\"bottom\"><\/i>\n<\/h6>"
test_str = ("<div class=\"panel-heading\">\n"
" <h6 class=\"panel-title\"><i class=\"icon-file-music2\"></i> TRXD - Sometimes.mp3\n"
"<i class=\" icon-info3 text-success\" data-popup=\"tooltip\" data-html=\"true\" title=\"<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7\" data-placement=\"bottom\"></i>\n\n"
"</h6>\n"
" </div>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.