import Foundation
let pattern = #"<h6 class="panel-title"><i class="icon-file-music2"><\/i>(.*?)<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="(.*)" data-placement="bottom"><\/i>\n<\/h6>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<div class="panel-heading">
<h6 class="panel-title"><i class="icon-file-music2"></i> TRXD - Sometimes.mp3
<i class=" icon-info3 text-success" data-popup="tooltip" data-html="true" title="<b>Uploaded on:</b><br/> 2017-11-14 06:56:54<br> <b>Downloads:</b><br/> 7" data-placement="bottom"></i>
</h6>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)