const regex = /\nREM\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\nREM\\s*', 'g')
const str = `Erzeugt einen textlichen Hinweis für den Fall, dass eine sekundäre Mengenangabe
REM durchgeführt wurde und dabei die zulässigen Toleranzen überschritten wurden
REM [task=29261]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);