#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([a-z])((?!\1)[a-z])(?:\1\2){2,}"
Local $sString = "asasasas" & @CRLF & _
"ghghghgh" & @CRLF & _
"aaaaaaaa" & @CRLF & _
"asas" & @CRLF & _
"abcabcabc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")