using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z])((?!\1)[a-z])(?:\1\2){2,}";
string input = @"asasasas
ghghghgh
aaaaaaaa
asas
abcabcabc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}