import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(\\S).{6,14}$";
final String string = "qwerty1\n"
+ "QWERTY1q\n"
+ "qwERTy\n"
+ "QWERTY1\n"
+ "QWER TY1q\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}