re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$/m
str = 'qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result