# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(?=(?:\d{3})+(?!\d))/ /gm;t' <<< "1000123,-
1000,-
1234
1000123.45678"