$re = '/(?<=\d)(?=(?:\d{3})+(?!\d))/m';
$str = '1000123,-
1000,-
1234
1000123.45678';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;