$re = '/https?:\/\/(?<domain>[^\/\s]+)/m';
$str = ' http://ctldl.windowsupdate.com/msdownload/update/v3/
https://www.facebook.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);