// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https?:\/\/(?<domain>[^\/\s]+)").unwrap();
let string = " http://ctldl.windowsupdate.com/msdownload/update/v3/
https://www.facebook.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}