using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"</item>\s*+([^i]*(?:i(?!tem)[^i]*)*)\s*</body>";
string input = @"<body>
<item>abc</item>
<item>def</item>
unparsable rest
</body>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}