$re = '~</item>\s*+([^i]*(?:i(?!tem)[^i]*)*)\s*</body>~is';
$str = '<body>
<item>abc</item>
<item>def</item>
unparsable rest
</body>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);