$re = '/\s\b(?!\s)/m';
$str = 'the quick brown fox jumps over the lazy dog A.S.A.P. That\'s that right, this happened.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);