re = /\s\b(?!\s)/m
str = 'the quick brown fox jumps over the lazy dog A.S.A.P. That\'s that right, this happened.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end