using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"big ([a-z]+)";
string input = @"The big boat has a big assortment of big things.";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}