$re = '/big ([a-z]+)/i';
$str = 'The big boat has a big assortment of big things.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);