using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w]+[\s\w]+[\w]+|\w+)(?!.*\()(?=.*\))";
string input = @"""heres:a:func('var 1', 'va r a 2', 'var3', 2)""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}