$re = '/([\w]+[\s\w]+[\w]+|\w+)(?!.*\()(?=.*\))/';
$str = '"heres:a:func(\'var 1\', \'va r a 2\', \'var3\', 2)"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);